for IntelliJ IDEA

167 234
Support for the Dart programming language.

Download plugin

Recent change notes

  • Improvements and bug fixes
Nick, manual dart2js call is no more a recommended workflow. There's Pub Build action and integration with Pub Serve instead. I'd like to discuss your workflow and why you need this action. Let's continue discussion in the forum, follow the link above.
I have upgraded to PHPStorm 8.0.2 and the latest dart plugin release. Since then the "compile to javascript" option in the context menu is gone. This feature was extremely useful in my workflow and I'd really like to have it back. Is that possible? Thanks Nick
@nocquidant: should work. Most likely some misconfiguration. I need details to find the cause: IDE version, what do you start for debug, where you set breakpoint and how project roots are configured. The best place to continue discussion is forum (link above) or if you are sure it is a bug, then issue tracker (link above as well). Also you can contact me directly if you follow AlexanderD link among plugin Authors.
Thank you for your work, but why I cannot set breakpoint inside the "lib" folder?! Nick
@Anonymous: I do not see any problems with the latest Polymer 0.9.5+2. What Polymer version do you use? Are there syntax errors in declaration.dart file? Click on my name and then 'Send e-mail' to contact me. Or use our public forum available on 'Forum page' link above.
cleared run config, in 13.3 EAP running dart plugin during debug I get the following: Internal error: 'package:polymer/src/declaration.dart': error: line 410 pos 24: right angle bracket expected Map _getPublishedProperties( have cleared packages and package cache / pub get and pub upgrade
@agifford, @drichan The latest Dart plugin version requires IntelliJ IDEA 13.1 EAP: http://confluence.jetbrains.com/display/IDEADEV/IDEA+13.1+EAP
I've been using IDEA 12 for about 5 months now and have really enjoyed it. I've just started using Dart and was quite surprised to find out that the latest Dart plugin for IDEA 12 is almost a year old (4/2013) and many versions and fixes behind what is available for 13. It is odd that the plugin updates that were released in August, September, etc before IDEA 13 came out aren't available for users of IDEA 12. I guess I need to figure out a way to get IDEA 13.
I have a similar problem installing the plugin. I am using IntelliJ 13.0.2 CE. On the Plugins Dialog when I choose to "Install JetBrains plugin..." It only lists the 132.835 version of Dart plugin available. If I try and use this I don't get a Dart Settings dialog button on the toolbar so I can't figure the dart tools. If I try and download the 134.1188 plugin by downloading to disk, and then installing it fails, because it seems to be missing some plugin descriptor file. The zip file only contains .jar files.
When I check from my Intellij 13 Ultimate install it shows 133.726 as the latest available version of the Dart plugin. I tried downloading version 134.1188 of the plugin and installing it manually, but when I try to install it I get an error in the IDE saying it is not compatible with my version of the software. I am using Intellij 13.0.2 (the latest version). Any suggestions?
Alexander, That fixed the issue thank you for the help.
@agifford I have sent a correctly configured project to you. To other readers: the project was configured incorrectly, pubspec.yaml file didn't belong to amy IntelliJ IDEA module. Correct configuration for this case is that IntelliJ IDEA project contains one module of Web type that has project root folder configured as a content root.
I just discovered the cause of the issue. It seems the pubspec.yaml context menu is not generated unless it is in the same directory as the dart file. I copied the file down in to my web directory and the build menu is now visible. I think this should be categorized as a bug, in the code I have come across it is common to have the Dart files be in a sub-directory under the pubspec.yaml. Even the samples included with the Dart SDK are structured this way.
@jw11ab: old plugin version (0.4.8) should be compatible with IntelliJ IDEA 12. But it is greatly outdated, because all redesign, improvements and bug fixes are introduced only in IntelliJ IDEA 13 compatible plugin versions. Currently the plugin requires IntelliJ IDEA Ultimate Edition, but pretty soon it will be compatible with free Community Edition. Watch http://youtrack.jetbrains.com/issue/WEB-10227 to be notified.
@agifford: > Project Structure->Project "No SDK". When I choose "New" the Dart SDK is not listed. That's ok, you only need to setup Dart SDK at Settings | Dart. > I don't see the "Dart: Build" That's strange. May I take a deeper look at your project setup? Please write me a message (click on AlexanderD in the Authors section and select 'send e-mail').
Please  sign in  to leave a comment.