EJS
for IntelliJ IDEA

Compatible with:  IntelliJ IDEA PhpStorm PyCharm RubyMine
22.12.2016
88 821
EJS support

Download plugin

Recent change notes

  • Initial support
03.11.2016
Is it possible to add compatibility for WebStorm? Sometimes I have to work with Underscore templates and this plugin looks like a proper decision for a correct syntax highlighting.
16.08.2016
Can you add an option to indent HTML inside EJS blocks? Like this:

<% if(true) { %> <.div> <% } %>

Now <.div> will be aligned with first <% when using autoformat. It should be indented.
Anonymous
10.12.2014
work very well very nice, thks
Anonymous
18.02.2014
There's no way to adjust indentations for ejs files and my html5 scopes stopped working (ie auto-compelete doesn't work).
31.01.2014
Vadorequest, EJS plugin is bundled to WebStorm. What do you mean by "doesn't work"? Could you post issue to http://youtrack.jetbrains.net/ . Thank you.
31.01.2014
Still doesn't works with WebStorm 7.0.3.
31.12.2013
Is it possible to add support for '-' postfix option for templates? This is supported feature in a popular Node.JS EJS module by visionmedia. It's used to 'slurp' new lines e.g., <% code -%> or <% -%> or <%= code -%> or <%- code -%>.
08.11.2013
I hope the plugin will be updated because we need it here! ;^)
Anonymous
29.10.2013
It doesn't work in current versión.
Anonymous
25.10.2013
doesn't work with current version!
Anonymous
16.10.2013
Using RubyMine 5.4 same error - plugin incompatible with current version
06.09.2013
I used pycharm 2.7.3 got the error ejs plugin is incompatible with current installation
Please  sign in  to leave a comment.