IntelliJ Code Golf

Compatible with  IntelliJ IDEA
29.08.2014
20 935
This plugin for IntelliJ IDEA allows to carry out competitions on knowledge of IDEA features (e.g. 'write this code using minimum number of keystrokes', 'transform one piece of code to another using minimum number of refactorings'). Invoke Code | 'Start Code Golf' to start.

Download plugin

Version

Update date

27.12.2015
This is pretty cool plugin, and with small improvements really useful as well! If i would be able to see how others achieved the small amount of key strokes, i would maybe learn something out of this. Also using live templates should be prevented. Now almost everything is possible to do with them which makes the high score pretty useless.
nik
10.03.2015
You need to have at least one source root in a module to start Code Golf. So you can either create an empty 'Java' project or mark some directory in 'store' module as a source root (Project View -> Popup Menu -> Mark Directory as -> Sources Root).
Anonymous
10.03.2015
Thank you for answer, I tried it and there is message after choosing any "task": "No source roots are defined in store".
nik
07.02.2015
To start solving tasks use 'Start Code Golf' item in 'Code' menu.
Anonymous
23.01.2015
i've registered on your website, downloaded plugin and filled my user name in configuration. How can i start and take first task? What i have to do to begin "playing golf with you"? ;)
Anonymous
16.09.2014
FYI You don’t require a licence against your account to make this plugin work.
Anonymous
28.08.2014
Cannot login to my JetBrains account with this plugin. After entering my credentials, I just get a window with title "Error", red exlamation mark sign and a OK button, with no message. Also, after logging in as guest I see a message "Cannot load tasks from http://code-golf.appspot.com, only predefined tasks are available", which leaves to practice "Hello World" task. Tested both on IDEA 13.1.4 and IDEA 14 EAP.
03.04.2014
How I can find out the best solution?
nik
27.05.2013
Version 0.1.1 should be compatible with JDK 6.
27.05.2013
Doesn't work when IDEA is running on Java 6
Please  sign in  to leave a comment.