Elm language plugin

Compatible with: IntelliJ IDEA PhpStorm WebStorm PyCharm RubyMine AppCode CLion Gogland DataGrip Rider Android Studio
11.03.2017
15 857
Plugin for Elm language support.

Features
  • Supports Elm 0.18 (If you need to have different version supported, see this link)
  • Parsing the syntax
  • Syntax highlighting and color settings page
  • Going to declaration
  • Highlighting unresolved references with a quick-fix option to add an import statement
  • Code completion
  • Spellchecking
  • Brace matching
  • Rename refactoring

Download plugin

Recent change notes

Fixed bugs: - GLSL code is not parsed as Elm code anymore, - "effect" can be used as a function name, - dot can be used in custom operators.