TestNG-J

Compatible with  IntelliJ IDEA
18.04.2007
44 038
TestNG Integration

Download plugin

Version

Update date

Anonymous
11.01.2015
WAAAAAYYYYYY out of date. Some nice featuresof TestNG cannot be used because it can't handle them.
Anonymous
16.11.2012
please, update the plugin!
27.09.2011
is it a dead plugin? no one update or maintains it anymore?
Anonymous
08.06.2011
Broken since 10.5 - IDEA puts 1.4 version of the testng.jar into the classpath, that leads to the error:

Exception in thread "main" java.lang.IllegalArgumentException: Cannot specify "JDK" with 1.4 version of TestNG
Anonymous
26.05.2011
Doesn't work with intellij 10.5
Anonymous
20.01.2011
I'd love to see IDEA support running tests in parallel. If JetBrains isn't willing to invest further in this plugin, can you provide the source so the community can take a stab at it?
Anonymous
26.10.2010
The TestNG version used by this plugin is very out of date.

Please update it!
Anonymous
06.05.2010
For one reason or another, you have to wait for several minutes before a test actually starts. I gave up using the plugin and simply tun my tests from the command line.
Anonymous
14.01.2010
is this working on IntelliJ 9?
Anonymous
20.10.2009
It appears development of this plugin has stopped. Meanwhile TestNG is still releasing new features that don't work with this plugin...
Anonymous
12.10.2009
If you accidentally install this on 8.1 on mac it will stop test NG from working. As indicated, uninstall the plugin, then mount the dmg file and copy the Contents/pugins/testng directory to the corresponding place in the app.
Anonymous
11.06.2009
DAMINT, FIX THE PLUGIN FOR 8.1
13.03.2009
The plugin for testNG is now bundled with Intellij; if like me you mistakenly installed this one you can first uninstall this one, and then re-install 8.1 over your current installation of intellij to recover the bundled plugin. I didn't lose any of my setups or settings in intellij by re-installing this way.
Anonymous
12.03.2009
This doesn't work in IntelliJ 8.1:

Anonymous
06.02.2009
This plugin do not work with IntelliJ 8

MAYDAY MAYDAY
Need to fix it ASAP by developper

or I'll have to switch bacl to JUnit !

PS : this comment crap thing doesn't work with Firefox !!
Beware IDEA, don't rely on your past success, Eclipse and IBM are still in the corner.
Please  sign in  to leave a comment.