Retrotranslator Integration

Compatible with  IntelliJ IDEA
04.07.2006
9 845
Automatically retrotranslate classes compiled by IDEA.
Generates classes compatible with 1.4 virtual machines from your Java 5 source code.
Now you can code using almost all new features in Java 5, compile, debug against a JVM 1.4 (selecting an alternative JRE), change your code, reload it, and continue debugging as usual.
All this can be done just selecting a check box in your module configuration and adding retrotranslator libraries to it.
Thanks to Taras Puchko, Retrotranslator author, for adding some extra functionality to his product to make this plugin development easier.
If you find this plugin useful and want to make a comment on it (bug, feature, whatever) feel free to send it to my email address.

Download plugin

Version

Update date

Recent change notes

  • 0.2.8
    • Retrotranslator 1.0.6 integrated.
01.10.2009
Java 1.4 got its end of life last year and now also Java 5 end of life is around the corner (next thursday), so with Sun encouraging everyone to move to newest versions of Java I think there's no need for this plugin
Anonymous
01.10.2009
This plugin seems not to work with Idea 8.0.x and 8.1.x, too bad :-(
21.11.2007
cannot work on Selena.
12.02.2007
what you mean with "advanced mode" ?
you can write me to my personal email address or to the plugin thread in jetbrains forums
Anonymous
12.02.2007
I like it but where can I activate advanced mode?
Anonymous
08.11.2006
great
Anonymous
06.06.2006
This plug-in has/does nothing special. To pump up it's rating with anonymous posts without comments is also not nice at all.
Anonymous
05.06.2006
Very useful plugin.
Please  sign in  to leave a comment.