Categories


logos

IntelliStripes

Products: IntelliJ IDEA

Vendor: Mario Arias, Evgeny Shepelyuk

Email:

Website: http://code.google.com/p/intellistripes

Source code: IntelliStripes_1528.zip

Stripes even more easy !!!
Downloads: 17106
Rating:
Participated in rating: 5
Version Compatible builds Date
3.0 beta 4 95.66 — 95.627 04.12.2010 Download
2.0.8 80.9013 — 85.* 23.10.2009 Download
2.0.6 80.9013 — 85.* 22.04.2009 Download
1.0.3.860 75.7860 — 75.7999 19.10.2008 Download
1.0.Final.860 75.7860 — 75.7999 07.10.2008 Download
1.0.RC1.860 75.7757 — 75.7999 12.08.2008 Download
0.7.5.584 72.7361 08.12.2007 Download
0.4.1.294 69.7123 26.09.2007 Download
0.1.1.111 69.7096 04.08.2007 Download
11 updates are hidden show all updates
Screenshot #1399
Screenshot #464
Screenshot #463
Screenshot #2545
Screenshot #513
Screenshot #1398
Screenshot #465
Screenshot #1396
Screenshot #550

Recent change notes

Third version for Maia

WARNING:This version is a beta version. Some bugs will be arised and some features will stop working

Comments:

JSAurora
2012-06-12 23:11:02
I recently installed a brand new copy of JetBrains Intellij 11.1.2 and this error came up. The project worked just fine in JetBrains Intellij 9.0.4 with no errors. The JetBrains 11.1.2 wouldn’t recognize the Stripes facet type even after I enabled the IntelliStripes and IntelliStripes-NV plugins. When I open the project, JetBrains 11.1.2 prompts with “Yes” and “No” option: Unknown facet type: 'Stripes' Would you like to ignore facet 'Stripes' from module 'Public'? In project structure, the Facets cannot load Stripes facet. It’s starting to be annoying. What’s weird to me is that I am able to start and/or debugging on server with JetBrains 11.1.2 but the error wouldn’t disappear. I have copied the stack trace of the error. What should I do about this? com/intellij/psi/impl/source/resolve/reference/PsiReferenceProvider [Plugin: IntelliStripes]: com/intellij/psi/impl/source/resolve/reference/PsiReferenceProvider [Plugin: IntelliStripes] com.intellij.diagnostic.PluginException: com/intellij/psi/impl/source/resolve/reference/PsiReferenceProvider [Plugin: IntelliStripes] at com.intellij.openapi.components.impl.ComponentManagerImpl$ComponentsRegistry.a(ComponentManagerImpl.java:465) at com.intellij.openapi.components.impl.ComponentManagerImpl$ComponentsRegistry.a(ComponentManagerImpl.java:431) at com.intellij.openapi.components.impl.ComponentManagerImpl$ComponentsRegistry.access$000(ComponentManagerImpl.java:417) at com.intellij.openapi.components.impl.ComponentManagerImpl.a(ComponentManagerImpl.java:101) at com.intellij.openapi.components.impl.ComponentManagerImpl.initComponents(ComponentManagerImpl.java:342) at com.intellij.openapi.components.impl.ComponentManagerImpl.init(ComponentManagerImpl.java:85) at com.intellij.openapi.project.impl.ProjectImpl.init(ProjectImpl.java:293) at com.intellij.openapi.project.impl.ProjectManagerImpl.a(ProjectManagerImpl.java:277) at com.intellij.openapi.project.impl.ProjectManagerImpl.a(ProjectManagerImpl.java:330) at com.intellij.openapi.project.impl.ProjectManagerImpl.access$400(ProjectManagerImpl.java:80) at com.intellij.openapi.project.impl.ProjectManagerImpl$9.compute(ProjectManagerImpl.java:549) at com.intellij.openapi.project.impl.ProjectManagerImpl$9.compute(ProjectManagerImpl.java:545) at com.intellij.openapi.progress.impl.ProgressManagerImpl$4.run(ProgressManagerImpl.java:256) at com.intellij.openapi.progress.impl.ProgressManagerImpl$TaskRunnable.run(ProgressManagerImpl.java:469) at com.intellij.openapi.progress.impl.ProgressManagerImpl$6.run(ProgressManagerImpl.java:288) at com.intellij.openapi.progress.impl.ProgressManagerImpl$2.run(ProgressManagerImpl.java:178) at com.intellij.openapi.progress.impl.ProgressManagerImpl.executeProcessUnderProgress(ProgressManagerImpl.java:218) at com.intellij.openapi.progress.impl.ProgressManagerImpl.runProcess(ProgressManagerImpl.java:169) at com.intellij.openapi.application.impl.ApplicationImpl$8$1.run(ApplicationImpl.java:641) at com.intellij.openapi.application.impl.ApplicationImpl$6.run(ApplicationImpl.java:434) at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441) at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303) at java.util.concurrent.FutureTask.run(FutureTask.java:138) at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) at java.lang.Thread.run(Thread.java:662) at com.intellij.openapi.application.impl.ApplicationImpl$1$1.run(ApplicationImpl.java:145) Caused by: java.lang.NoClassDefFoundError: com/intellij/psi/impl/source/resolve/reference/PsiReferenceProvider at java.lang.Class.forName0(Native Method) at java.lang.Class.forName(Class.java:247) at com.intellij.openapi.components.impl.ComponentManagerImpl$ComponentsRegistry.a(ComponentManagerImpl.java:441) ... 26 more Caused by: java.lang.ClassNotFoundException: com.intellij.psi.impl.source.resolve.reference.PsiReferenceProvider PluginClassLoader[IntelliStripes, 0.7.5.584] at com.intellij.ide.plugins.cl.PluginClassLoader.loadClass(PluginClassLoader.java:77) at java.lang.ClassLoader.loadClass(ClassLoader.java:247) ... 29 more
.
chabala
Rated:
2011-06-06 20:22:01
Could we please have an updated version that will work with IDEA 10?
.
Anonymous
2008-11-28 10:22:39
See Bad Class Version Number Error ......

Would Please compile it use JDK 1.5,
Because We Use JDK 1.5 on Working .....

Thanks
.
Mario Arias
2008-09-29 05:58:59
For those interested on IntelliStripes for Diana; we have uploaded a beta version in the IntelliStripes site (http://code.google.com/p/intellistripes), in downloads section.

Thanks
.
Mario Arias
2008-09-16 20:52:47
We are working on that
.
Anonymous
2008-09-16 19:58:50
Is there a Diana compatible version?
.
Anonymous
Rated:
2008-02-02 04:24:00
Excellent plugin. The custom completion of tag attrs in the JSP is really helpful.
.
sammyrulez
Rated:
2007-10-24 12:17:09
Amazing
.
Anonymous
Rated:
2007-10-03 12:50:34
.
Mario Arias
2007-08-27 19:24:09
A bug is present in the last version (0.1.2.241) when you add a new stripes facet, I'll fixed soon
.
Anonymous
Rated:
2007-08-01 02:02:03
.
Mario Arias
2007-07-30 06:44:42
Yes 7.0m1b id the build # 6833, this plugin only works for build # 7096 and superior, you can download the last EAP from : http://www.jetbrains.net/confluence/display/IDEADEV/Selena+EAP
.
Anonymous
2007-07-30 05:04:07
cannot work with 7.0m1b, startup error.
.