JProfiler

Compatible with  IntelliJ IDEA
11.06.2016
172 697
The official JProfiler plugin for ej-technologies' JProfiler. Enables remote profiling of selected run configuration with JProfiler from within IDEA. Requires JProfiler 8.0 or higher.

Download plugin

Version

Update date

Anonymous
07.01.2015
the latest version of jprofiler is not compatible with intellij idea 13. how can i use it?
27.10.2011
10.5 version is long around. Support is missing. Good I havent bought it
Anonymous
15.06.2011
+1 for 10.5 integration!

Desperately need 10.5 integration
Anonymous
17.05.2011
Yes, please support IntelliJ 10.5
17.05.2011
Unfortunately, the current 10.5 release of IDEA is not supported. Any news concerning an update?
Anonymous
02.02.2011
No IdeaX EAP support (yet), which is sad, because the recent versions of the Scala-plugin require EAP versions.
Anonymous
02.02.2011
An error occurred when trying to obtain information about the selected JVM:

VMARGS: -agentpath:C:\PROGRA~1\JPROFI~1\bin\WINDOW~1\jprofilerti.dll=${PARAM} -Djprofiler.64bit=true

java.lang.Throwable
at com.intellij.openapi.diagnostic.Logger.error(Logger.java:48)
at com.jprofiler.integrations.idea.base.c.showError(c.java:2)
at com.jprofiler.integrations.protocol.Connector.showError(Connector.java:450)
at com.jprofiler.integrations.protocol.Connector.invokeArgumentsHelper(Connector.java:230)
at com.jprofiler.integrations.protocol.Connector.queryProfilingParameters(Connector.java:183)
at com.jprofiler.integrations.idea.base.ProfilerService.a(ProfilerService.java:16)
at com.jprofiler.integrations.idea.b.d.a(d.java:2)
at com.jprofiler.integrations.idea.b.d.a(d.java:5)
at com.jprofiler.integrations.idea.cache.a.run(a.java:3)
at com.intellij.openapi.progress.impl.ProgressManagerImpl$TaskRunnable.run(ProgressManagerImpl.java:3)
at com.intellij.openapi.progress.impl.ProgressManagerImpl$4.run(ProgressManagerImpl.java:1)
at com.intellij.openapi.progress.impl.ProgressManagerImpl$2.run(ProgressManagerImpl.java:5)
at com.intellij.openapi.progress.impl.ProgressManagerImpl.executeProcessUnderProgress(ProgressManagerImpl.java:13)
at com.intellij.openapi.progress.impl.ProgressManagerImpl.runProcess(ProgressManagerImpl.java:101)
at com.intellij.openapi.application.impl.ApplicationImpl$7$1.run(ApplicationImpl.java:3)
at com.intellij.openapi.application.impl.ApplicationImpl$5.run(ApplicationImpl.java:8)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
at java.util.concurrent.FutureTask.run(FutureTask.java:138)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
at java.lang.Thread.run(Thread.java:619)
at com.intellij.openapi.application.impl.ApplicationImpl$1$1.run(ApplicationImpl.java:5)
Anonymous
14.08.2010
Hi i solve this problem.
\"Select the JProfiler executable location(jprofiler.exe). Since there is no .exe it is impossible to do this. You guys can do better than this\"
Download setup file from http://www.ej-technologies.com/download/jprofiler/files.html.
Anonymous
03.08.2010
Same problem. How to install??
Anonymous
25.05.2010
I tried this in 8.1.2. When I download it gets a .jar file. When I click on the profiler icon it wants me to "Select the JProfiler executable location(jprofiler.exe). Since there is no .exe it is impossible to do this. You guys can do better than this
Anonymous
12.05.2010
This is a great profiler and great integration with intellij
Anonymous
05.05.2010
Why did you change the icons? The old ones were so much nicer...
Anonymous
19.02.2010
Amazing that the plugin simply doesn't work with version 9.
Anonymous
10.02.2010
The new version of the plugin works with IntelliJ IDEA 9. Thank's for that!

But it is not possible to connect to older versions of JProfiler (e.g. 5.2.2).
Will there be a support for older JProfiler versions?
Anonymous
13.01.2010
I can't believe this plug-in doesn't work in idea9 ! How much longer until it happens?
Please  sign in  to leave a comment.