Categories


opensource software

Dart

Products: IntelliJ IDEA, RubyMine, PhpStorm, PyCharm, AppCode, Android Studio

Vendor: JetBrains

Email: N/A

Website: N/A

SourceCode: https://github.com/JetBr...plugins/tree/master/Dart

License: http://www.apache.org/licenses/LICENSE-2.0

Bugtracker page

Forum page

Description:

Support for Dart programming language
Downloads: 66680
Rating:
Participated in rating: 10
Version Since Build Until Build File/URL Size (Kb) Date Details
139.2. 139.1. 139.*. Download 2424.91 2014-10-07 15:56:58 details
138.2492. 138.2492. 138.*. Download 2419.01 2014-09-26 17:16:04 details
138.2453. 138.2453. 138.*. Download 2406.69 2014-09-26 17:15:29 details
138.1977. 138.1901. 138.*. Download 2400.32 2014-09-01 18:50:09 details
138.1495. 138.1495. 138.*. Download 2399.43 2014-08-06 17:27:23 details
138.1262. 138.1161. 138.*. Download 2389.42 2014-07-22 17:28:30 details
138.558. 138.532. 138.*. Download 2389.81 2014-06-11 18:00:13 details
138.369. 138.369. 138.*. Download 2377.63 2014-05-29 14:34:01 details
138.35. 138.1. 138.*. Download 2333.7 2014-04-30 14:07:21 details
135.765. 135.690. 135.*. Download 2335.15 2014-04-25 12:32:33 details
136.1710. 136.1672. 136.*. Download 2308.78 2014-04-21 10:17:13 details
135.697. 135.689. 135.*. Download 2311.7 2014-04-15 15:39:13 details
135.547. 135.475. 135.*. Download 2295.04 2014-03-27 11:58:23 details
136.1262. 136.1. 136.*. Download 2292.84 2014-03-20 19:53:59 details
135.425. 135.1. 135.*. Download 1809.04 2014-03-12 17:55:07 details
134.1188. 134.1160. 134.*. Download 1806.09 2014-02-19 16:21:16 details
133.726. 133.696. . Download 1738.78 2014-01-27 19:32:38 details
133.432. 133.330. . Download 1729.51 2013-12-26 16:40:36 details
131.19. 130.1. 131.*. Download 526.12 2013-12-09 15:07:38 details
133.239. 133.193. . Download 1732.17 2013-12-06 17:03:06 details
132.1045. 132.1045. . Download 1739.82 2013-11-13 10:31:11 details
132.835. 132.835. . Download 1668.27 2013-10-29 11:07:15 details
132.207. 132. . Download 546.47 2013-09-12 16:41:07 details
131.17. 130.1. . Download 545.75 2013-08-30 13:22:59 details
0.5.1. 129.1. . Download 525.1 2013-04-15 21:51:20 details
127.61. 127.1. 128.1. Download 520.79 2013-03-13 12:56:51 details
0.5. 128.1. 129.1. Download 520.72 2013-03-01 16:22:05 details
0.4.9. 126.329. 127.1. Download 520.62 2013-02-21 20:59:59 details
0.4.8. 126.1. 127.1. Download 537.14 2013-02-15 15:16:47 details
0.4.8. 123.1. 124.1. Download 541.45 2013-01-25 16:07:54 details
0.4.2. 122.520. 123.1. Download 518.79 2012-10-30 15:28:51 details
0.4.2. 121.333. 122.1. Download 518.41 2012-10-30 11:48:50 details
0.4.1. 122.263. 122.520. Download 514.75 2012-10-18 18:37:28 details
0.4. 121.149. 122.1. Download 514.83 2012-10-17 00:47:14 details
0.3.6. 122. 123.1. Download 452.84 2012-08-24 17:45:24 details
0.3.6. 121. 122.1. Download 453.42 2012-08-24 16:31:20 details
0.3.4. 120. 121.1. Download 373.88 2012-07-27 11:36:12 details
0.3.4. 117.105. 118.1. Download 373.75 2012-07-23 22:45:09 details
0.1. 107.199. 108. Download 26.91 2011-10-17 21:04:39 details
. .
22 updates are hidden show all updates

Recent change notes:

  • Dart command line apps debugger: support isolates (requires Dart SDK 1.7+)
  • Pub get/update/build output shown in Messages tool window tab
  • Various improvements and bug fixes

Comments:

123>
AlexanderD
2014-04-28 12:23:36
@Anonymous: I do not see any problems with the latest Polymer 0.9.5+2. What Polymer version do you use? Are there syntax errors in declaration.dart file? Click on my name and then 'Send e-mail' to contact me. Or use our public forum available on 'Forum page' link above.
.
Anonymous
2014-04-27 02:37:06
cleared run config, in 13.3 EAP running dart plugin during debug I get the following: Internal error: 'package:polymer/src/declaration.dart': error: line 410 pos 24: right angle bracket expected Map _getPublishedProperties( have cleared packages and package cache / pub get and pub upgrade
.
AlexanderD
2014-03-03 10:45:53
@agifford, @drichan The latest Dart plugin version requires IntelliJ IDEA 13.1 EAP: http://confluence.jetbrains.com/display/IDEADEV/IDEA+13.1+EAP
.
Splaktar
Rated:
2014-03-01 11:53:52
I've been using IDEA 12 for about 5 months now and have really enjoyed it. I've just started using Dart and was quite surprised to find out that the latest Dart plugin for IDEA 12 is almost a year old (4/2013) and many versions and fixes behind what is available for 13. It is odd that the plugin updates that were released in August, September, etc before IDEA 13 came out aren't available for users of IDEA 12. I guess I need to figure out a way to get IDEA 13.
.
drichan
2014-02-26 07:56:38
I have a similar problem installing the plugin. I am using IntelliJ 13.0.2 CE. On the Plugins Dialog when I choose to "Install JetBrains plugin..." It only lists the 132.835 version of Dart plugin available. If I try and use this I don't get a Dart Settings dialog button on the toolbar so I can't figure the dart tools. If I try and download the 134.1188 plugin by downloading to disk, and then installing it fails, because it seems to be missing some plugin descriptor file. The zip file only contains .jar files.
.
agifford
2014-02-24 01:00:51
When I check from my Intellij 13 Ultimate install it shows 133.726 as the latest available version of the Dart plugin. I tried downloading version 134.1188 of the plugin and installing it manually, but when I try to install it I get an error in the IDE saying it is not compatible with my version of the software. I am using Intellij 13.0.2 (the latest version). Any suggestions?
.
agifford
Rated:
2014-02-07 19:52:48
Alexander, That fixed the issue thank you for the help.
.
AlexanderD
2014-02-07 12:07:55
@agifford I have sent a correctly configured project to you. To other readers: the project was configured incorrectly, pubspec.yaml file didn't belong to amy IntelliJ IDEA module. Correct configuration for this case is that IntelliJ IDEA project contains one module of Web type that has project root folder configured as a content root.
.
agifford
2014-02-07 11:53:51
I just discovered the cause of the issue. It seems the pubspec.yaml context menu is not generated unless it is in the same directory as the dart file. I copied the file down in to my web directory and the build menu is now visible. I think this should be categorized as a bug, in the code I have come across it is common to have the Dart files be in a sub-directory under the pubspec.yaml. Even the samples included with the Dart SDK are structured this way.
.
AlexanderD
2014-02-07 11:24:52
@jw11ab: old plugin version (0.4.8) should be compatible with IntelliJ IDEA 12. But it is greatly outdated, because all redesign, improvements and bug fixes are introduced only in IntelliJ IDEA 13 compatible plugin versions. Currently the plugin requires IntelliJ IDEA Ultimate Edition, but pretty soon it will be compatible with free Community Edition. Watch http://youtrack.jetbrains.com/issue/WEB-10227 to be notified.
.
AlexanderD
2014-02-07 11:19:05
@agifford: > Project Structure->Project "No SDK". When I choose "New" the Dart SDK is not listed. That's ok, you only need to setup Dart SDK at Settings | Dart. > I don't see the "Dart: Build" That's strange. May I take a deeper look at your project setup? Please write me a message (click on AlexanderD in the Authors section and select 'send e-mail').
.
jw11ab
2014-02-07 09:46:36
The plugin doesn't seem to work with IntelliJ IDEA 12 Ultimate. I have tried on two different installations and got Incompatible plugin when trying to install it.
.
agifford
2014-02-06 21:30:55
I am using Intellij 13 Ultimate. I enabled the Dart SDK in the latest version of the plugin under Project Settings -> Dart. However, I don't see the "Dart: Build" option when I right click on my pubspec.yaml file. I notice that when I go to Project Structure->Project "No SDK" is listed under my Project SDK. When I choose "New" the Dart SDK is not listed. Am I missing a step here? Thanks.
.
Anonymous
Rated:
2013-11-30 19:38:01
override method and getter setter generator doesnt wotk in php storm 7.1 eap build
.
AlexanderD
2013-10-30 10:54:36
Dart SDK is now configured at Settings(Preferences) | Dart.
.
123>