Categories


Authors:
neuro159
free software

PHP

Products: IntelliJ IDEA

Vendor: JetBrains

Email: N/A

Website: N/A

Bugtracker page

Forum page

Description:

PHP 5.3/5.4/5.5 editing and debugging, PHPUnit, Smarty and various frameworks support
Downloads: 359639
Rating:
Participated in rating: 12
Version Since Build Until Build File/URL Size (Kb) Date Details
139.173. 138.1404. . Download 5171.77 2014-10-29 01:21:50 details
138.1161. 136.1029. . Download 5118.26 2014-07-16 16:32:44 details
138.826. 136. . Download 5103.01 2014-06-27 17:50:34 details
134.1456. 134.1300. . Download 4952.83 2014-03-06 22:09:13 details
133.982. 133.620. 134. Download 4869.68 2014-02-25 23:00:52 details
131.374. 132.719. 133. Download 4745.41 2013-10-22 18:15:37 details
130.1639. 130.1365. . Download 4672.12 2013-08-17 00:15:08 details
129.814. 129.1. . Download 4465.62 2013-06-28 13:28:22 details
127.100. 126.330. . Download 4305.82 2013-03-13 13:29:54 details
123.66. 122.850. . Download 4080.02 2012-12-05 20:40:39 details
121.390. 118.430. . Download 3867.23 2012-11-04 01:56:02 details
117.746. 112. 117.*. Download 3645.97 2012-07-15 03:37:46 details
111.344. 111. 112. Download 3396.05 2012-03-01 02:53:35 details
. .
18 updates are hidden show all updates
Screenshot #11484

Recent change notes:

PhpStorm 8.0.2 EAP 139.173 version

Comments:

123>
omervk
Rated:
2014-09-17 18:17:29
The plugin is not supported on IntelliJ IDEA 14 EAP IU-138.2210.3.
.
Anonymous
2014-08-23 05:09:08
v138.1751. "Plugin 'com.jetbrains.php' failed to initialize and will be disabled. Please restart IntelliJ IDEA. java.lang.NoSuchMethodError: com.intellij.openapi.util.LowMemoryWatcher.register(Ljava/lang/Runnable;Lcom/intellij/openapi/Disposable;)V" Exception when open one project in Intellij IDEA 138.1696
.
Anonymous
2014-08-04 10:55:29
This wouldn't work for the community version. Right?
.
Anonymous
2014-07-31 21:08:55
plz make php 5.4,5.5 plugin for Idea ultimate version 11.0.2
.
Anonymous
2014-06-02 19:22:16
Any chance of getting the source released for this, so the community can add support for hacklang?
.
Anonymous
Rated:
2014-05-28 00:13:15
Thank you for the solution for running php with intellij idea with 13.1.3 :)
.
Anonymous
2014-05-27 17:24:25
.
Anonymous
Rated:
2014-05-27 09:25:17
incompatible with build IU-135.909
.
rxlabz
Rated:
2014-05-10 00:40:29
incompatible with build IU-135.815
.
Anonymous
2014-03-06 19:46:52
For those complaining about plugin not working, you know you can go back to 13.0~?
.
Anonymous
2014-03-06 18:16:49
Should we expect an update to this plugin or just start using WebStorm?
.
john.degey
2014-03-06 17:30:15
EAP 13.1 build 134.1445 is not compatible with php 133.982...
.
Anonymous
Rated:
2014-03-03 14:17:01
133.982 still doesn't work with 13.1 EAP
.
epoplive
Rated:
2014-02-27 02:49:23
1160 does not work, keeps erroring: Could not save application settings: com.jetbrains.php.arrangement.PhpRearranger.getSerializer()Lcom/intellij/psi/codeStyle/arrangement/ArrangementSettingsSerializer;
.
john.degey
2014-02-26 03:57:38
IDEA EAP 134.1160 + PHP 133.982 always the same problem as turya describe it. No files can be opened, css, php ,js etc... Just impossible to work with it
.
123>