Compatible with:  IntelliJ IDEA , PhpStorm , RubyMine
1 037 353
Support for AngularJS and Angular 2

Download plugin

This is what I had to do to make this plugin work: - Settings -> Languages and Frameworks -> Javascript -> Libraries - From "In the Libraries area, click the Add button. In the New Library dialog box that opens, specify the name of the library. Click the Add button add next to the list of library files and choose Attach Files or Attach Directory on the context menu, depending of whether you need separate files or an entire folder. Select the Angular.js or Angular.min.js, or an entire directory in the dialog box that opens. IntelliJ IDEA returns to the New Library dialog box where the Name read-only field shows the name of the selected files or folder." - Settings -> Languages and Frameworks -> Template Data Languages - Choose the folder/s where your HTML templates are, then click on column Template data language and select your new library, and confirm with OK. I wonder why it has to be so difficult :(
Plugin 162.74.17 won't work with latest EAP 2016.2 (which is 162.74.16) :-(
@alturic, this plugin is for IntelliJ IDEA, RubyMine and PhpStorm where it's not bundled. WebStorm has this plugin included by default.
@dudewad, would you be so kind to create an issue in our tracker:, some additional information may be required
@alturic the plugin is to support angularjs bindings, etc. It provides intellisense between your angular classes and templates amongst other functionality. That's not considered "web" functionality, it's framework-specific, which is probably why they bundle it as a plugin since a lot of devs that do web programming won't do angularjs programming. Better to have that functionality as "optional".
It works, however it absolutely destroys editor performance. I will not use it simply because it makes my IDE worthless, even after doubling heap size/etc multiple times. Would give it a 4 or even a 5 if performance weren't impacted so heavily. I've seen performance impact on mac osx, win 8.1, and win 10 environments, all machines with between 12 and 32 gigs of ram.
I couldn't install it in Intellj Idea version 2016.1.1. Why, it doesn't support intelliJ Idea the lastest version?
My IntelliJ download the plugin AngularJS can not be used, 2 computers are successfully installed can not be used, for help
Am I missing something or does WebStorm not support AngularJS by default? I'm confused on what this plugin is "for"?
I had the same problem with the EAP, so I opened about it.
Plugin doesn't seem to be available for IntelliJ EAP 14. It reports 138.1988 as the latest version. Perhaps 139.12 is an incorrect version number?
So I have $interpolateProvider in a coffee file (although also tried a js file) and it doesn't seem enough to let this plugin know that the {{ has been changed to something else, instead I get various errors. Using PHPStorm8, with blade templates
Hi guys, if anyone ever runs into the problem that this plugin doesn't work: apparently you have to enable it by going to Settings | JavaScript | Libraries. Add checkboxes there, and it works.
Request data- prefixes!
i can't elaborate on how slow this plugin makes Rubymine. i don't know if the plugin is the only issue. but i have a late-2013 fully loaded 15" macbookpro and i was getting a good 250-500ms lag between keypress and action. i had to disable the plugin...
Please  sign in  to leave a comment.