Osmorc

Compatible with:  IntelliJ IDEA , Android Studio , Rider
17.03.2016
28 854
This plugin adds support for the development of OSGi-based applications to IDEA

Download plugin

Version

Update date

Recent change notes

Version 1.4.8
  • Bug fixes
Version 1.4.7
  • Bug fixes
Version 1.4.6
  • Compatible with IDEA 14.1
  • Bnd/Bndtools project import
  • Bnd Run Configurations
Version 1.4.5
  • Compatible with IDEA 14
  • Minor fixes
Version 1.4.4
  • Compatible with IDEA 13
  • Framework runners reworked to support modern versions
  • PAX Runner dropped

General usage instructions

First, go to settings -> OSGI -> IDE Settings -> Framework Definitions and add the OSGi framework that you want to work with (Equinox, Felix, etc.). Then add the OSGi facet to any module that should be an OSGi bundle. You can either write your own manifest or let the plugin calculate the manifest for you. To run an OSGi bundle create a new OSGi run configuration and select the framework that you set up in the first step. Then add the bundles you want to run. The plugin will run all dependencies automatically, so you don't need to manually add them. Finally run the newly created run configuration. If you chose to enable the OSGi console you can then send commands to the OSGi container and start/stop bundles.