1820 TeamCity Integration Tools integration 19 JetBrains, s.r.o. 3 439206 yaegor pluginrobot Vladislav.Rassokhin 2016-10-24 10.0.42318

TeamCity Integration

Compatible with all products except MPS
24.10.2016
439 206
Integration with JetBrains TeamCity - innovative solution for continuous integration and build management.

Download plugin

General usage instructions

After installation, log in to your TeamCity server. If server protocol differs, plugin would ask to download compatible version directly from TeamCity server.
10.11.2016
> Plugin for 8.1 not working for me, ..... Plugin version 8.1.x does not support IDEs newer than IDEA 15 (released in 2015)
10.11.2016
Plugin for 8.1 not working for me, get error during login "Login error: Cannot construct jetbrains.buildServer.users.UserData as it does not have a no-args constructor" Any suggestions? TeamCity Enterprise 8.1.5 (build 30240) PyCharm 2016.2.3 Build #PY-162.1967.10, built on September 7, 2016
07.10.2016
> Is it possible to login to a TeamCity server which is using GitHub authentication? IDE plugin can only login using username and password. If you can login to TeamCity using web login page by providing username/password that will also work in IDE plugin.
07.10.2016
Is it possible to login to a TeamCity server which is using GitHub authentication?
04.02.2016
It is a useful tool to keep builds in check. I just can't see, why it doesn't run the build for the current branch that is used in IntelliJ, it uses instead the default branch of my TeamCity configuration. This means I have to make a configuration for every feature branch that I am working on... not the best solution. Or am I doing something wrong?
02.12.2014
@simy4 please ask questions in the forum. TeamCity IDEA plugin should correspond to the TeamCity server version and can be downloaded from TeamCity installation. Different TeamCity versions have different IDEA compatibility: http://tinyurl.com/lo5qnap In general, it is recommended to upgrade both TeamCity and IntelliJ IDEA as the latest versions are always compatible. The plugin is not open source as noted by the license link.
02.12.2014
What's with compatibility for this plugin? I'm using an old version of TeamCity that requires an older version of this plugin but older version doesn't work on IDEA 14 or even IDEA 13! What should I do? Or even: where can I find the sources for this plugin to fix this issue for me?
28.12.2012
Don't work with Intellij IDEA 12.0.1 Plug-in don't redraw its canvas after going to "Customize Build" "Customize Build" lets only select Build Agent but don't change Build Configuration Options
17.11.2010
> why haven't you updated to 5.1.5 teamcity plugin?

No specific reason.

The plugin here is just for easier installation as you need to use the plugin of the same version as the TeamCity server you are running. Hence, usual procedure is to install the plugin, then login and update the plugin from the TeamCity server.
Anonymous
17.11.2010
why haven't you updated to 5.1.5 teamcity plugin?
Please  sign in  to leave a comment.