ULC Plugin

Compatible with  IntelliJ IDEA
3 266
Plugin for Rich Internet Application development with Canoo's UltraLightClient (ULC) library.

The ULC plugin provides the following functionality:
  • ULC Facet: conveniently manage the ULC installations available on your computer (as you do for JDKs), assign a specific ULC installation to a module, specify the ULC libraries to be put on the class path, specific for each module. Easily switch between different ULC versions. Source code stubs and JavaDocs are automatically available.
  • ULC Application Class Template: use 'New' -> 'ULC Application Class' to create an empty ULC application class, configure the ULC file template using 'IDE Settings' -> 'File Templates'.
  • ULC Run Configuration: simply configure, run and debug your ULC application class without the need for a main-method, configure ULC-specific parameters such as carrier stream provider, data stream provider, coder registry providers, log level, connection type, user parameters and init parameters.
  • ULC Code Inspections: increase productivity and reduce error count by using ULC-specific code inspections such as check for static references to ULCProxy instances, missing dispatchers on ULCProxy subclasses and missing scroll pane around model-based widgets.
  • This plugin is compatible with ULC 6.1.x and ULC 6.2.x

Download plugin

Recent change notes

  • 1.9.3 - Added ULC facet and additional code inspections, new ULC application class template
  • 1.9.2 - Fix for reset of "export" flag for ULC module library on apply
  • 1.9.1 - Fix for IllegalDataException when serializing UlcModuleConfigurationSettingsImpl and no ULC installation is selected
  • 1.9.0 - Initial version for IDEA 6.x compatibility, ULC installation configuration, ULC run configuration

No comments so far.

Please  sign in  to leave a comment.