AngularJS

Products: IntelliJ IDEA, RubyMine, PhpStorm

Vendor: johnlindquist, JetBrains

Website: https://github.com/JetBr...ns/tree/master/AngularJS

Bugtracker page

Support for AngularJS
Downloads: 791934
Rating:
Participated in rating: 12
Version Compatible builds Date
145.844.3 145.844 — 146 06.04.2016 Download
145.596.9 145.596 — 146 26.03.2016 Download
145.258.3 145.258 — 146 18.03.2016 Download
145.184.5 145.184 — 146 02.03.2016 Download
144.2925.4 144.2925 + 15.01.2016 Download
143.379.19 143.379 + 26.10.2015 Download
143.110 143.110 + 07.10.2015 Download
142.5028 142.5028 + 22.09.2015 Download
142.4651 142.4651 + 08.09.2015 Download
142.4081 142.4081 + 20.08.2015 Download
142.2481 142.2481 + 18.06.2015 Download
142.1935 142.1935 + 26.05.2015 Download
141.1237 141.1237 + 22.05.2015 Download
141.991 141.991 + 06.05.2015 Download
141.2 141.2 + 06.03.2015 Download
140.1968 140.1968 + 27.01.2015 Download
139.1112 139.1112 + 19.01.2015 Download
139.12 139.12 + 09.10.2014 Download
138.1988 138.1988 + 15.09.2014 Download
138.1242 138.1029 + 21.07.2014 Download
135.1063 134.1172 + 02.07.2014 Download
134.1094 134.1 + 13.02.2014 Download
0.1.9 107.105 + 27.09.2013 Download
11 updates are hidden show all updates
Screenshot #13184

Comments:

123>
hoolen
Rated:
2016-04-18 09:06:16
I couldn't install it in Intellj Idea version 2016.1.1. Why, it doesn't support intelliJ Idea the lastest version?
.
wap816
Rated:
2016-04-06 13:42:10
My IntelliJ download the plugin AngularJS can not be used, 2 computers are successfully installed can not be used, for help
.
alturic
2015-09-22 02:18:21
Am I missing something or does WebStorm not support AngularJS by default? I'm confused on what this plugin is "for"?
.
hho
2014-10-10 11:32:19
I had the same problem with the EAP, so I opened https://youtrack.jetbrains.com/issue/WEB-13716 about it.
.
dalexiuc
2014-10-10 04:21:51
Plugin doesn't seem to be available for IntelliJ EAP 14. It reports 138.1988 as the latest version. Perhaps 139.12 is an incorrect version number?
.
Anonymous
2014-10-01 06:08:19
So I have $interpolateProvider in a coffee file (although also tried a js file) and it doesn't seem enough to let this plugin know that the {{ has been changed to something else, instead I get various errors. Using PHPStorm8, with blade templates
.
Bodiam
2014-09-30 14:12:15
Hi guys, if anyone ever runs into the problem that this plugin doesn't work: apparently you have to enable it by going to Settings | JavaScript | Libraries. Add checkboxes there, and it works.
.
miraage
2014-07-22 09:32:23
Request data- prefixes!
.
dcunited001
2014-06-15 11:22:49
i can't elaborate on how slow this plugin makes Rubymine. i don't know if the plugin is the only issue. but i have a late-2013 fully loaded 15" macbookpro and i was getting a good 250-500ms lag between keypress and action. i had to disable the plugin...
.
Rayz
2014-06-04 12:50:37
Version 135.937 causes the cursor to jump around when I hit the return key. It always jumps to a variable about halfway down the page. Makes editing impossible. Has anyone else seen this?
.
Rhinox
2014-05-31 21:42:19
hello, i have installed the plugin from repository on Intellij Idea but I still get the ng directives highlighted. Am i supposed to do anything else ? I did the clear casche and restart thing. I am using it in static web project
.
rubensayshi
Rated:
2014-04-22 13:05:30
this plugin doesn't do syntax highlighting as plugins for similar syntaxted template engines (twig, jinja2, django) do right? or am I missing something here .. ?
.
malyshevalex
2014-04-14 02:08:55
Hello. I have the same issue like @ptinkler. Angular's html attributes like ng-app, ng-controller e.t.c was highlighted as errors. Idea 13.1
.
ptinkler
2014-04-02 17:25:28
@enDal that's great, thanks! :)
.
enDal
2014-04-02 17:22:28
@ptinkler oops, it seems that it bundled only in not-yet released 3.4 EAP. I'll enable it for PyCharm, but only 0.1.9 version will be compatible with very basic html attributes completion
.
123>