Downloads: 87921
Rating:
Participated in rating: 10
Version Compatible builds Date
141.614 141.178 — 141.* 10.04.2015 Download
141.318 141.177 — 141.* 24.03.2015 Download
141.210 141.175 — 141.* 18.03.2015 Download
141.7 141.1 — 141.* 03.03.2015 Download
140.2667 140.2667 — 140.* 24.02.2015 Download
140.2109 140.2015 — 140.* 02.02.2015 Download
139.848 139.225 — 139.* 22.12.2014 Download
135.1302 135.1289 — 135.* 29.10.2014 Download
139.231 139.173 — 139.* 28.10.2014 Download
139.2 139.1 — 139.* 07.10.2014 Download
138.2492 138.2492 — 138.* 26.09.2014 Download
138.2453 138.2453 — 138.* 26.09.2014 Download
138.1977 138.1901 — 138.* 01.09.2014 Download
138.1495 138.1495 — 138.* 06.08.2014 Download
138.1262 138.1161 — 138.* 22.07.2014 Download
138.558 138.532 — 138.* 11.06.2014 Download
138.369 138.369 — 138.* 29.05.2014 Download
138.35 138.1 — 138.* 30.04.2014 Download
135.765 135.690 — 135.* 25.04.2014 Download
136.1710 136.1672 — 136.* 21.04.2014 Download
135.697 135.689 — 135.* 15.04.2014 Download
135.547 135.475 — 135.* 27.03.2014 Download
136.1262 136.1 — 136.* 20.03.2014 Download
135.425 135.1 — 135.* 12.03.2014 Download
134.1188 134.1160 — 134.* 19.02.2014 Download
133.726 133.696 27.01.2014 Download
133.432 133.330 26.12.2013 Download
131.19 130.1 — 131.* 09.12.2013 Download
133.239 133.193 06.12.2013 Download
132.1045 132.1045 13.11.2013 Download
132.835 132.835 29.10.2013 Download
132.207 132 12.09.2013 Download
131.17 130.1 30.08.2013 Download
0.5.1 129.1 15.04.2013 Download
127.61 127.1 — 128.1 13.03.2013 Download
0.5 128.1 — 129.1 01.03.2013 Download
0.4.9 126.329 — 127.1 21.02.2013 Download
0.4.8 126.1 — 127.1 15.02.2013 Download
0.4.8 123.1 — 124.1 25.01.2013 Download
0.4.2 122.520 — 123.1 30.10.2012 Download
0.4.2 121.333 — 122.1 30.10.2012 Download
0.4.1 122.263 — 122.520 18.10.2012 Download
0.4 121.149 — 122.1 17.10.2012 Download
0.3.6 122 — 123.1 24.08.2012 Download
0.3.6 121 — 122.1 24.08.2012 Download
0.3.4 120 — 121.1 27.07.2012 Download
0.3.4 117.105 — 118.1 23.07.2012 Download
0.1 107.199 — 108 17.10.2011 Download
23 updates are hidden show all updates

Recent change notes

  • Check for the available Dart SDK update
  • Various improvements and bug fixes

Comments:

123>
AlexanderD
2014-12-17 15:00:53
Nick, manual dart2js call is no more a recommended workflow. There's Pub Build action and integration with Pub Serve instead. I'd like to discuss your workflow and why you need this action. Let's continue discussion in the forum, follow the link above.
.
dafen
2014-12-17 14:20:14
I have upgraded to PHPStorm 8.0.2 and the latest dart plugin release. Since then the "compile to javascript" option in the context menu is gone. This feature was extremely useful in my workflow and I'd really like to have it back. Is that possible? Thanks Nick
.
AlexanderD
2014-11-20 14:53:23
@nocquidant: should work. Most likely some misconfiguration. I need details to find the cause: IDE version, what do you start for debug, where you set breakpoint and how project roots are configured. The best place to continue discussion is forum (link above) or if you are sure it is a bug, then issue tracker (link above as well). Also you can contact me directly if you follow AlexanderD link among plugin Authors.
.
nocquidant
2014-11-20 14:43:14
Thank you for your work, but why I cannot set breakpoint inside the "lib" folder?! Nick
.
AlexanderD
2014-04-28 12:23:36
@Anonymous: I do not see any problems with the latest Polymer 0.9.5+2. What Polymer version do you use? Are there syntax errors in declaration.dart file? Click on my name and then 'Send e-mail' to contact me. Or use our public forum available on 'Forum page' link above.
.
Anonymous
2014-04-27 02:37:06
cleared run config, in 13.3 EAP running dart plugin during debug I get the following: Internal error: 'package:polymer/src/declaration.dart': error: line 410 pos 24: right angle bracket expected Map _getPublishedProperties( have cleared packages and package cache / pub get and pub upgrade
.
AlexanderD
2014-03-03 10:45:53
@agifford, @drichan The latest Dart plugin version requires IntelliJ IDEA 13.1 EAP: http://confluence.jetbrains.com/display/IDEADEV/IDEA+13.1+EAP
.
Splaktar
Rated:
2014-03-01 11:53:52
I've been using IDEA 12 for about 5 months now and have really enjoyed it. I've just started using Dart and was quite surprised to find out that the latest Dart plugin for IDEA 12 is almost a year old (4/2013) and many versions and fixes behind what is available for 13. It is odd that the plugin updates that were released in August, September, etc before IDEA 13 came out aren't available for users of IDEA 12. I guess I need to figure out a way to get IDEA 13.
.
drichan
2014-02-26 07:56:38
I have a similar problem installing the plugin. I am using IntelliJ 13.0.2 CE. On the Plugins Dialog when I choose to "Install JetBrains plugin..." It only lists the 132.835 version of Dart plugin available. If I try and use this I don't get a Dart Settings dialog button on the toolbar so I can't figure the dart tools. If I try and download the 134.1188 plugin by downloading to disk, and then installing it fails, because it seems to be missing some plugin descriptor file. The zip file only contains .jar files.
.
agifford
2014-02-24 01:00:51
When I check from my Intellij 13 Ultimate install it shows 133.726 as the latest available version of the Dart plugin. I tried downloading version 134.1188 of the plugin and installing it manually, but when I try to install it I get an error in the IDE saying it is not compatible with my version of the software. I am using Intellij 13.0.2 (the latest version). Any suggestions?
.
agifford
Rated:
2014-02-07 19:52:48
Alexander, That fixed the issue thank you for the help.
.
AlexanderD
2014-02-07 12:07:55
@agifford I have sent a correctly configured project to you. To other readers: the project was configured incorrectly, pubspec.yaml file didn't belong to amy IntelliJ IDEA module. Correct configuration for this case is that IntelliJ IDEA project contains one module of Web type that has project root folder configured as a content root.
.
agifford
2014-02-07 11:53:51
I just discovered the cause of the issue. It seems the pubspec.yaml context menu is not generated unless it is in the same directory as the dart file. I copied the file down in to my web directory and the build menu is now visible. I think this should be categorized as a bug, in the code I have come across it is common to have the Dart files be in a sub-directory under the pubspec.yaml. Even the samples included with the Dart SDK are structured this way.
.
AlexanderD
2014-02-07 11:24:52
@jw11ab: old plugin version (0.4.8) should be compatible with IntelliJ IDEA 12. But it is greatly outdated, because all redesign, improvements and bug fixes are introduced only in IntelliJ IDEA 13 compatible plugin versions. Currently the plugin requires IntelliJ IDEA Ultimate Edition, but pretty soon it will be compatible with free Community Edition. Watch http://youtrack.jetbrains.com/issue/WEB-10227 to be notified.
.
AlexanderD
2014-02-07 11:19:05
@agifford: > Project Structure->Project "No SDK". When I choose "New" the Dart SDK is not listed. That's ok, you only need to setup Dart SDK at Settings | Dart. > I don't see the "Dart: Build" That's strange. May I take a deeper look at your project setup? Please write me a message (click on AlexanderD in the Authors section and select 'send e-mail').
.
123>