PHP

Compatible with  IntelliJ IDEA
22.08.2016
800 084
PHP 5.3-7 editing and debugging, PHPUnit, Smarty, Twig and various frameworks support

Download plugin

Version

Update date

05.02.2016
Opening php files fails (editor is not opened) using php plugin version 144.3168 (with IntelliJ IDEA 15.0.3 / Mac OS 10.10.4 / Java Runtime Environment 1.6). After downgrading to previous plugin release (143.1770), editing php files works again.
10.12.2015
why couldn't use in Android sutdio,Can you support
19.04.2015
I can't understand why people complains about a product they are using for FREE (EAP) for any kind of issue it can have. That is exactly a EAP build is for, test everything is working right before sell it to some professional interested to use this product PAYING.
20.03.2015
没有中文版,哼!
Anonymous
17.02.2015
PHP support is not guaranteed in future releases
Anonymous
16.02.2015
It's been 6 days since new IntelliJ EAP was released and PHP plugin still doesn't work :/
16.02.2015
It's the same every new EAP release. I've notified them several times and they really don't seem to care. The people responsible for the PHP part are different from the people doing the editor. I guess the only thing they need to guarantee on a release is that you can write Java with it, PHP is apparently not as important.
dwr
13.02.2015
Plugin doesn't work with the latest IntelliJ IDEA 14 EAP :(
12.02.2015
This plugin page (and all others) should make it very obvious which versions of IntelliJ IDEA it works with. I just wasted my time trying to get it to work with the latest version of the "Community Edition", finally checking the "details" link to see that CE isn't supported.
12.02.2015
Which version of IntelliJ IDEA does this work with? I have version 14.0.3. When I tried to install this plugin, I received this error message: - - - - Plugin PHP depends on unknown plugin com.intellij.css - - - - After that, it acted as though installation was successful. It prompted me whether to restart IntelliJ, so I did. After startup, I received this similar error message: - - - - Plugin Error Problems found loading plugins: Plugin "PHP" was not loaded: required plugin "com.intellij.css" not installed. - - - - Along with links to disable PHP or to open the plugin manager.
Anonymous
12.02.2015
webstorm not support php https://devnet.jetbrains.com/message/5441904#5441904
Anonymous
11.02.2015
The plugin is not supported on WebStorm
Anonymous
11.02.2015
The plugin is not supported on IntelliJ IDEA 14 EAP IU-140.2285.5
11.02.2015
I got the message Plugin "PHP" was not loaded: required plugin "com.intellij.css" not installed. How can I solve this error?
17.09.2014
The plugin is not supported on IntelliJ IDEA 14 EAP IU-138.2210.3.
Please  sign in  to leave a comment.