Ruby

Compatible with  IntelliJ IDEA
20.09.2016
699 113
The Ruby plug-in makes IntelliJ IDEA the smart Ruby and Ruby on Rails editor, ideal for the full cycle application development. Resources:
RubyMine and Ruby plugin blog
Discussion forum
Issue tracker
Troubleshooting and FAQs

Download plugin

Version

Update date

12.02.2016
I am unable to download this plugin. It gets through most of the download, and then fails with an error message that is different for different browsers. From IE it says "download was interrupted". From Chrome it says "Network error". I initially thought (and am still suspicious) that it is something on my end, perhaps the antivirus software mandated by my employer. But disabling the AV protection doesn't seem to fix the problem and our local IT group insist that there's nothing on our end that could be interrupting the download. Are other people able to download the Ruby plugin?
Anonymous
09.12.2015
Does it fit community edition of IDEA?
Anonymous
16.05.2015
I can't seem to find Ruby in the list of IntelliJ IDEA plugins to install under the settings menu. Is the only way to manually install this from file?
05.03.2015
That last comment should have read: "The latest IDEA EAP is build 141.2.2. We have one plugin version that supports builds up to 140.*, and another that supports builds starting with 141.14. I.e., there's no Ruby plugin available for this EAP. Please fix!
05.03.2015
The latest IDEA EAP is build 141.2.2. We have one plugin version that supports builds up to 140.*, and another that supports builds starting with 141.2.14. I.e., there's no Ruby plugin available for this EAP. Please fix!
03.09.2014
working great on EAP 138.1980.1
30.08.2014
also getting unsupported on 138.1696.2. Have uninstalled and reinstalled as well.
30.08.2014
Running IntellJ IDEA 138.1696.2 I get an error that Ruby plugin ruby-7.0.0.20140807 is not supported. Any repo for a more latest?
17.04.2014
FYI: Seemed to not be supported running with IntelliJ 135.689. Uninstalling the plugin and reinstalling seems to have resolved the problem.
16.04.2014
lasest version of plugin says that is is compatible with 135.* build of IDEA. But build 135.689 says that Ruby plugin not supported
Anonymous
27.01.2014
to see if a version is compatible with your intellij look at Since Build
Anonymous
25.11.2013
I have the licensed version of Intellij 12.1.6 and the latest ruby plugin still doesn't work.
25.11.2013
Intellij 12.1.6 does not work with version 6 of ruby 6.0.0.20131121 or 6.0.0.20131106 on mac. not sure about others
10.10.2013
Is there a problem with IDEA 12.1.6 (129.1359) and the 3rd July version of this plugin? Presumably later versions wont work as they need a higher version of IDEA (13 presumably)
Anonymous
08.06.2013
Works fine with IntelliJ 12. You need to have the licensed edition for it to work. It's not free.
Please  sign in  to leave a comment.