Play 2.0 Support

Compatible with  IntelliJ IDEA
29.08.2014
382 670
Play 2.0 Framework support

Download plugin

Version

Update date

Recent change notes

Critical fixes update.
02.12.2014
Hi guys, Had some rough time with Intellij 14 and suspect they are in the way the cache is implemented but might also be in this plugin. Just in case, posting here for Jetbrains review. http://blog.jetbrains.com/scala/2014/10/30/scala-plugin-update-for-intellij-idea-14-rc-is-out/#comment-87900
04.09.2014
This plugin will be part of Scala plugin for IDEA 14. With IDEA 13 it's still compatible.
Anonymous
04.09.2014
Does not seem to be compatible with the scala plugin 1.0 and idea 13..
15.08.2014
When creating a run configuration for 'Play 2 App', if you edit the JVM Options and accidentally put extra spaces in between the options, IDEA will add empty string arguments in the exec string, which trips the java command. -Xms512M -Xmx4000M -XX:+CMSClassUnloadingEnabled -XX:MaxPermSize=256M execs /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home/bin/java -agentlib:jdwp=transport=dt_socket,address=127.0.0.1:65327,suspend=y,server=n -Dfile.encoding=UTF8 -Djline.terminal=none -Dsbt.log.noformat=true -Dsbt.global.base=/private/var/folders/g6/3vp_t21s73z36q8n8vz2qx64000vhx/T/sbt-global-plugin4964025616454751330stub -Xms512M -Xmx4000M "" -XX:+CMSClassUnloadingEnabled -XX:MaxPermSize=256M -classpath "/Users/jp283u/Library/Application Support/IntelliJIdea13/Scala/launcher/sbt-launch.jar:/Applications/IntelliJ IDEA 13.app/lib/idea_rt.jar" xsbt.boot.Boot run Not sure if is general issue with handling JVM options field in all dialogs...
05.08.2014
I can't install this plugin on IntelliJ 13.1.4 on OSX Mavericks.
23.07.2014
Can't install the plugin on IDEA 13.1.4 Windows version
12.05.2014
Mostly works, but has problems with HTTPS. If I do -Dhttps.port=9443, I get java.net.BindException: Address already in use. This works fine when running Play directly (without IDEA). Seems to be related to the appending "run 9443" to the command line.
29.04.2014
I also would love to have back the Go To navigation in the i18n messages.
Anonymous
28.04.2014
Great plugin, thanks for the awesome job! There's a feature, however, I would like to have it back, once it worked in IntelliJ IDEA 12, but not in 13: the navigation to the messages (i18n) declaration. In IDEA 12 I could cmd+click on a i18n message (e.g.: '@Messages("main.navigation.home")') to go to its declaration in the Play! messages file. In the other hand, I could also find usages of messages in template (.scala.html) files. Can you put this back?
14.04.2014
Very annoying. When building the project in idea, this "thing" gets in the way and tries to resolve all sort of dependencies that are already resolved and in the ivy cache. It's further broken because it does not use idea proxy settings. I don't want this plugin to do anything when building! there's no need to, SBT already does it!
07.04.2014
I am using IntelliJ IDEA 13.1 and the support for play framework in this version is really good. But there is one really annoying error: adding a global import for my templates in Build.scala like this templatesImport += "_root_.helper.models.nestedset.interfaces.Node", There are no compile errors but it is not recognized by the IDE and even worst, there is no auto completion available. Adding the complete class within the import fixes that problem but I have to do this in every template like this: @(node: _root_.helper.models.nestedset.interfaces.Node) Does anybody found a workaround for this? There is already a bug reported since October 2012: http://youtrack.jetbrains.com/issue/SCL-4762 I have already started a thread in play user group (https://groups.google.com/forum/#!topic/play-framework/NKXJ_1M4kJg) and IntelliJ Developer Community (http://devnet.jetbrains.com/message/5512446#5512446) with no results
25.02.2014
Are you on IDEA 12? It's fixed in IDEA 13.
Anonymous
24.02.2014
We desperately need the sub-package view support. Any idea on when this can be fixed? Thanks.
Anonymous
14.02.2014
Is there any news on sub-package view support? Still doesn't work for me. And also I get errors when using play-java and reverse-routing to methods that take a String argument. return redirect(routes.Application.say("hello")); Produces the error: say (string) in ReverseApplication cannot be applied to (java.lang.String)  
18.12.2013
Hi, Aaron, We will upload version for IDEA 12.x with some important fixes at the end of this week. Best regards, Alexander Podkhalyuzin.
Please  sign in  to leave a comment.