Google App Engine Integration
for IntelliJ IDEA

Compatible with  IntelliJ IDEA
14.10.2009
22 224
The plugin is bundled with IDEA Ultimate Edition since version 9.
Provides support for developing Google App Engine applications. The following features are available:
  • option on "Technologies" page of the module wizard to quickly create an AppEngine project
  • inspection to report forbidden code in App Engine application
  • run configuration for Google App Engine Dev server
  • option to run JDO or JPA Enhancer on make (in Google App Engine Facet settings)
  • action for uploading an application to Google (Tools | Upload App Engine Application)

Download plugin

Recent change notes

  • support for AppEngine SDK 1.2.6
21.12.2011
Hey that was great to read. Thanks for the great post .Loved every part of it.
07.07.2011
Wow! amazing content! Thank you the better understanding about Ebooks. This will really help me to bring my business into success. As what i have observe, this is a very good training ground of business marketing. I hope everybody have read this content.
01.07.2011
great posting
01.07.2011
really this post is very good.
30.06.2011
well i think this post is relatively so different and important
Anonymous
17.06.2011
All day I always surf in the internet to read some more information here. I noticed that there are lots of comments posted here and it helps me a lot to because
Anonymous
17.06.2011
numarul actiunilor de mobile marketing au crescut spectaculos in Romania, tot mai multe branduri alegand sa foloseasca acest nou canal de comunicare.
Anonymous
07.10.2010
This page says that the google app engine is available for community edition as well : http://www.jetbrains.com/idea/features/google_app_engine.html


However, the plugin is not supported even in the Maia CE version. Nor does it appear in the CE plugins list.

Too bad :(
nik
16.06.2010
The plugin is bundled to IDEA Ultimate starting from version 9.
Anonymous
08.05.2010
Is this being updated for version 9?
21.03.2010
Are you working on a version for IDEA 9?
12.01.2010
Could you help me and say how to use GAE Plugin with GWT? When I started AppEngine Dev Server I had an exception: java.lang.NoClassDefFoundError: com/google/gwt/user/client/rpc/RemoteService.
17.09.2009
Great plugin!!!
Anonymous
13.07.2009
Why don't you support JPA?
nik
19.06.2009
We don't have plans to make the plugin compatible with IDEA 7.x.
Please  sign in  to leave a comment.