Go Lang Plugin
for IntelliJ IDEA

Compatible with all products
23.12.2016
691 150

Basic support for Go programming language.

For advanced support please see Gogland.

Download plugin

General usage instructions

After the plugin is installed any file named *.go inside the source path for the current module will be parsed and highlighted as a go source code file. You will also need to download / compile and define a Go SDK in order to be able to compile and run go applications. If you encounter any issues with the plugin, please report them on the bug tracker: https://github.com/go-lang-plugin-org/go-lang-idea-plugin/issues.
15.01.2017
I'm getting the error message "Plugin Go lang plugin is incompatible with this installation" I am on linux mint 18.1. This is for BOTH webstorm and IDEA. I have them both installed to /home/user/apps/.
29.11.2016
why do they have a download that isn't compatible with web storm?
11.10.2016
Best Plugin available for Go. Full support for refactoring now.
07.07.2016
Working with it for half a year now and it just works perfectly, thanks a lot! I would really like to donate something...
28.02.2016
Need more refactoring options especially extract method.
Anonymous
24.12.2015
Need more refactoring options. And It would be good if it worked in PyCharm as well as intelliJ
Anonymous
15.12.2015
will work in the Android Studio?
17.10.2015
It's very fragile. Plugin updates will often break functionality that previously worked fine. I would wait until it's (at least) version 1.0 and thoroughly tested and vetted. IntelliJ is of course primarily a Java IDE, and its concept of setup for other lang SDKs do not often match with Go's. Syntax highlighting works, but the rest isn't reliable.
Anonymous
27.09.2015
Killer plugin!
Anonymous
03.09.2015
Works incredibly well!!
22.08.2015
Still a lot to be done, e.g. refactorings, but a very nice plugin!
27.05.2015
Tried the new weekly alpha version today - simply loved it. I really like the way it is progressing. It definitely will become the defacto IDE for golang (for non vim/emacs people)!!!
Anonymous
08.04.2015
This version is working pretty well with webstorm 0.9.256 141.2 — 141.* 08.04.2015
Anonymous
09.03.2015
I really like this plugin, waiting for new release
16.02.2015
This plugin is great so far! Looking forward to future releases.. thanks!
Please  sign in  to leave a comment.