PostCSS support
for IntelliJ IDEA

13.01.2017
4 885

This plugin brings support for PostCSS:

  • The IDE now recognises .pcss files. You can also enable PostCSS support for your .css files in Preferences | Languages & Frameworks | Stylesheets | Dialects.
  • Syntax highlighting for PostCSS syntax. You can additionally configure it in Preferences | Editor | Colors & Fonts.
  • Intelligent code completion.
  • Configurable Code style and auto-formatting.
  • Go to declaration, Go to symbol, and Find usages actions are available for custom selectors and custom media queries.
  • Rename custom selectors and custom media queries with ease.

The following PostCSS plugins are supported:

Download plugin

18.01.2017
Hello, this is a great plugin! Please add support for PostCSS plugins like: - postcss-import - postcss-mixins - postcss-calc and others if possible :)
16.01.2017
Hi, you claim support of postcss-nesting, but the following code shows me syntax errors just after the & character (a term expected) : .wrapper { display: flex; @nest .no-flexbox & { display: block; } }
22.12.2016
Please Intellij .sss files are a must! Postcss with sugar syntax rocks
30.11.2016
Any plans to include syntax SugarSS (*.sss)?
20.11.2016
Installing 163.5644.1 plugin on PhpStorm 163.7743.39 results in exception: "Plugin 'org.intellij.plugins.postcss' failed to initialize and will be disabled. Please restart PhpStorm."
10.10.2016
twolf434@gmail.com, this plugin is compatible only with 2016.3 EAP
10.10.2016
Trying to get this working with IntelliJ IDEA 2016.2.4 Build #IU-162.2032.8, built on September 9, 2016 JRE: 1.8.0_112-release-b343 x86_64 JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o I am getting an error during installation of the zip file. It is saying the plugin is incompatible with this installation? Any plans to make this available? Cheers
08.10.2016
Seems like phpstorm is not supported yet. By the way, it would be good to be able to automatically enable all the stuff from webstorm in phpstorm as from what I know that's subset.
The latest version of PHPStorm refuses to install this plugin saying it's incompatible. Anyone have any idea what the deal is?
@kbytin, thank you for reply. To help us understand what happened, please create an issue in our bug tracker https://youtrack.jetbrains.com/issues/WEB. Screenshots and a full log file (Help -> Show logs...) would be very helpful.
@dimkasta, you can vote for https://youtrack.jetbrains.com/issue/WEB-37 issue. It also will be very helpful, if you will describe in issue comments what functionality this support should provide.
07.09.2016
I don't see dropdown for manual setting. WebStorm 2016.3 EAP Build #WS-163.3512.13, built on September 1, 2016 WebStorm EAP User Expiration date: October 1, 2016 JRE: 1.8.0_112-release-b325 amd64 JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
05.09.2016
Nice :) Any plans to include autoprefixer in the supported plugins?
30.08.2016
@ahmadbadpey@gmail.com, you need to go to Settings | Plugins | Install JetBrains plugin. Please note that you need 2016.3 EAP of the product you're using to install it
30.08.2016
@hutber, yes, you need 2016.3 EAP of the product to install this plugin
Please  sign in  to leave a comment.