Node Security

Compatible with: IntelliJ IDEA PhpStorm WebStorm PyCharm RubyMine AppCode CLion GoLand DataGrip Rider MPS Android Studio
Feb 06, 2018
318
Node Security
GitHub | Issues | Donate with PayPal

IntelliJ Node Security plugin that indicates which Node packages in your project are vulnerable.
Plugin checks your dependencies against [nodesecurity.io](nodesecurity-io) service.

Features
  • Highlight vulnerable dependencies in `package.json` file.
  • Verify package.json files when project is opened


Download plugin

Recent change notes

v0.3.0 (2018-02-06)

Full Changelog

Implemented enhancements:
  • Support package.json external updates (#1)
  • Memoize VulnerabilitiesScanner for better performance
Fixed bugs:
  • Unexpected token exception in Advisory.isVulnerable (#4, #5)
Full Changelog History