XQuery Support

Compatible with: IntelliJ IDEA PhpStorm WebStorm PyCharm RubyMine AppCode CLion Gogland DataGrip Rider MPS Android Studio
Apr 10, 2017
35 110
Provides support for XQuery language in version 3.0 and 3.1

Download plugin

Recent change notes

Please check new documentation page with the list of features and useful shortcuts applicable to the plugin. Please participate in the SURVEY to make the plugin even better!

3.3.0:

  • Issue #211 - Update to Idea 2017.1 by Ivan Lagunov.
  • Issue #156 - XQuery 3.1 support.
  • Issue #183 - XML element not highlighted when entering an element node before `()`.
  • Issue #198 - Valid expressions of the form `... < (...)` are reported as errors.
  • Issue #204 - Order by modifier warning when followed by where.
  • Multi-word keyword completion and Grammar-Kit upgrade.