SAP/Open UI5

Compatible with: IntelliJ IDEA PhpStorm WebStorm PyCharm RubyMine AppCode CLion Gogland DataGrip Rider MPS Android Studio
Apr 03, 2016
6 382
This is the SAP/Open UI5 Plugin for IDEA Platforms.

Download plugin

Recent change notes

Version 2.05
  • Update UI5 libraries to 1.36.5
Version 2.04
  • Make Index.html lowercase on project creation to prevent bug running on linux
Version 2.03
  • Added more xsd documents on project creation.
  • Change language default to english.
Version 2.02
  • Added xsd to xml type projects for autocompletion for xml views.
  • Added css file to html file generated.
Version 2.01
  • Added autocomplete functionality.
  • SAP UI5 resource files are added once project is created.
  • SAP UI5 run configuration is added once project is created.
  • Update UI5 Run Configuration to run static content on a webserver without java.
  • Change build version and what idea products can use the plugin.
  • Fixed UI components.
  • Fixed code generation errors.
Version 2.0
  • Complete rewrite of the plugin.