Back JetForcer | The Smartest Force.com IDE 2.0.15.191

Dependencies defined in plugin.xml

  • (optional) AngularJS
  • (optional) JavaScript
  • (optional) com.intellij.css
  • (optional) com.intellij.modules.coverage
  • com.intellij.modules.vcs
  • com.intellij.modules.xml

Supported products

List of supported products was determined by dependencies defined in the plugin.xml.

Product name Compatible versions
Android Studio build 191.6183.87 — 191.*
CLion 2019.1.1 — 2019.1.4
DataGrip 2019.1 — 2019.1.4
GoLand 2019.1.1 — 2019.1.4
IntelliJ IDEA Ultimate 2019.1 — 2019.1.4
IntelliJ IDEA Community 2019.1 — 2019.1.4
IntelliJ IDEA Educational 2019.1 — 2019.1.2
AppCode 2019.1 — 2019.1.5
PhpStorm 2019.1 — 2019.1.4
PyCharm Professional 2019.1.1 — 2019.1.4
PyCharm Community 2019.1.1 — 2019.1.4
PyCharm Educational 2019.1 — 2019.1.2
Rider 2019.1 — 2019.1.3
RubyMine 2019.1 — 2019.1.4
WebStorm 2019.1.1 — 2019.1.4

Unsupported products

Product name Incompatible dependencies
MPS com.intellij.modules.xml

Notes

  • Redesign:
    • Resolve
    • Type Inference System
    • Code Completion
    • Retrieve Metadata System
    • Reimplement DB Viewer
  • BugFix:
    • JF-1801 Retrieval error