marklogic-intellij-plugin

Compatible with: IntelliJ IDEA PhpStorm WebStorm PyCharm RubyMine AppCode CLion GoLand DataGrip Rider MPS Android Studio
Jan 24, 2018
323

MarkLogic integration, providing an error log viewer, and support for running and profiling the following query types on MarkLogic:

  1. XQuery
  2. Server-side JavaScript (MarkLogic 8 or later)
  3. SQL (MarkLogic 8 or later, run only)
  4. SPARQL Query (MarkLogic 7 or later, run only)
  5. SPARQL Update (MarkLogic 8 or later, run only)

Download plugin

Recent change notes

Release 0.2.1:

Run Configuration:

  1. Determine the MarkLogic version from the MarkLogic server.

Bug Fixes:

  1. Report the correct namespace-qualified type names for types on MarkLogic >= 8.0.
  2. Fix an exception when running queries with IntelliJ 2017.3.
  3. Support MarkLogic version numbers like '9.0-3'.
  4. Improve reporting various error conditions.
  5. Add IntelliJ 2018.1 support.